PAT-1002 A+B for Polynomials

1002 A+B for Polynomials(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

#include<stdio.h>
#include<map>
#include<vector>
using namespace std;


int main(){
	int k1,k2;
	scanf("%d",&k1);
	vector<pair<int,double> > p1;
	for(int i=0;i<k1;i++){
		int e;double a;
		scanf("%d %lf",&e,&a);
		p1.push_back(make_pair(e,a));
	}
	scanf("%d",&k2);
	vector<pair<int,double> > p2;
	for(int i=0;i<k2;i++){
		int e;double a;
		scanf("%d %lf",&e,&a);
		p2.push_back(make_pair(e,a));
	}
	int i1=0,i2=0;
	vector<pair<int,double> > ans;
	while(i1<k1&&i2<k2){
		if(p1[i1].first==p2[i2].first){
			double tmp=p1[i1].second+p2[i2].second;
			if(tmp!=0){
				ans.push_back(make_pair(p1[i1].first,tmp));
			}
			i1++;i2++;
		}else if(p1[i1].first>p2[i2].first){
			ans.push_back(p1[i1]);
			i1++;
		}else if(p2[i2].first>p1[i1].first){
			ans.push_back(p2[i2]);
			i2++;
		}
	}
	for(;i1<k1;i1++){
		ans.push_back(p1[i1]);
	}
	for(;i2<k2;i2++){
		ans.push_back(p2[i2]);
	}

	printf("%d",ans.size());
	for(int i=0;i<ans.size();i++){
		printf(" %d %.1f",ans[i].first,ans[i].second);
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值