杭电1020 之 Encoding

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
  
  
2 ABC ABBCCC

Sample Output
  
  
ABC

A2B3C

分析:刚开始用的map,它会自动排序,处理了一下还是不行,题目说的是子串子串子串!!!!例如AACCCBBC,应该输出2A3C2BC

错误代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <map>
using namespace std;
const int maxn=1e4+10;

map<char,int> mp;
char a[maxn];
int b[27];

int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        cin>>a;
        memset(b,0,sizeof(b));
        mp.clear();
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            mp[a[i]]++;
        }
        for(int i=0;i<len;i++)
        {
            if(b[a[i]-'A']==0)
            {
                if(mp[a[i]]>1) cout<<mp[a[i]];
                cout<<a[i];
                b[a[i]-'A']++;
            }
        }
        cout<<endl;
    }
    return 0;
}


AC代码如下:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
const int maxn=1e4+10;

string str;

int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        cin>>str;
        int count=1;
        str[str.length()]='0';
        int len=str.length();
        for(int i=0;i<len;i++)
        {
            if(str[i]==str[i+1]) count++;
            else
            {
                if(count>1) cout<<count;
                cout<<str[i];
                count=1;
            }
        }
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值