设计一个People类

设计一个People 类,该类的数据成员有姓名、年龄、身高、体重和人数,其中人数为静态数据成员,成员函数有构造函数、显示和显示人数。其中构造函数由参数姓名、年龄、身高和体重来构造对象;显示函数用于显示人的姓名、年龄、身高和体重;显示人数函数为静态成员函数,用于显示总的人数。

输入格式:

按姓名、年龄、身高和体重依次输入每个人的信息
已exit结束
zhang 18 180 70
li 20 160 50
exit

输出格式:

输出总人数,例如
2

输入样例:

在这里给出一组输入。例如:

zhang 18 180 70
li 20 160 50
exit

输出样例:

在这里给出相应的输出。例如:

2

 #include <iostream>
using namespace std;
class People
{
    public:
        People(string n,int a,int h,int w)
        {
            name=n;
            age=a;
            height=h;
            weight=w;
            count++;
        }
        static int getcount()
        {
        return count;
        }
    private:
        string name;
        int age,height,weight;
        static int count;
};
int People::count=0;
int main()
{
    string name;
    int age,height,weight;
    while((cin>>name>>age>>height>>weight)&&(name!="exit"))
    {
        People p(name,age,height,weight);
        
    }
    cout<<People::getcount();
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值