大理石在哪(UVa10474)
问题描述:
现有N个大理石,每个大理石上写了一个非负整数、首先把各数从小到大排序;然后回答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上写着x。排序后的大理石从左到右编号为1~N。
输入大理石数量和需要回答问题数量,然后输入大理石上的每个非负整数,接着输入x
样例输入:
4 1
2 3 5 1
5
5 2
1 3 3 3 1
2 3
样例输出:
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3
代码实现:
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int n,m,x,y,sum=1,a[1000];
while(scanf("%d%d",&n,&m)==2&&n){
printf("CASE# %d:\n",sum++);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
while(m--){
scanf("%d",&x);
y=lower_bound(a,a+n,x)-a;//在已排序数组a中寻找x(用于查找大于或等于x的第一个位置)
if(a[y]==x)
printf("%d found at%d\n",x,y+1);
else
printf("%d notfound\n",x);
}
}
}