Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用数组!
#include <stdio.h>
#include <stdlib.h>
#include<malloc.h>
struct node
{
int data;
struct node *next;
};
struct node *h1,*p1,*t1;//完整链表的三要素头指针,移动指针,尾指针
struct node *h2,*p2,*t2;
int main()
{
int m,n;
scanf("%d%d",&m,&n);//下面开始建表
h1=(struct node *)malloc(sizeof(struct node));
h2=(struct node *)malloc(sizeof(struct node));
h1->next=NULL;
h2->next=NULL;
t1=h1;
t2=h2;
while(m--)
{
p1=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p1->data);
p1->next=NULL;
t1->next=p1;
t1=p1;
}
while(n--)
{
p2=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p2->data);
p2->next=NULL;
t2->next=p2;
t2=p2;
}
struct node *h,*t,*p;/*这里P可要也可不要,P可用t来代替*/
h=h1;
p1=h1->next;
p2=h2->next;
free(h2);//表二的头部不要了
t=h1;//合并表的尾指针一开始指向其头部
while(p1&&p2)
{
if(p1->data>p2->data)/*比较两链表元素大小,谁小谁先插入*/
{
t->next=p2;
t=p2;
p2=p2->next;
}
else
{
t->next=p1;
t=p1;
p1=p1->next;
}
if(p1)t->next=p1;/*最后可能会有一表空一表不空,判断一下找出非空表,直接将非空表后半部分整体插入,跳出循环。*/
else t->next=p2;
}
p=h->next;
while(p->next)
{
printf("%d ",p->data);
p=p->next;
}
printf("%d",p->data);
return 0;
}