杭电1232_畅通工程(并查集)——java

Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。 
 

Sample Input
 
 
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
 

Sample Output
 
 
1
0
2
998


import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while (sc.hasNextInt()) {
            int N = sc.nextInt();
            if (N == 0)
                break;
            int M = sc.nextInt();
            int[] set = new int[N + 1];
            for (int i = 1; i <= N; i++) {
                set[i] = i;
            }
            for(int i = 1;i <= M ;i++){
                int from = sc.nextInt();
                int to = sc.nextInt();
                relation(set,from,to);
            }
            int count = 0;
            for(int i = 1;i <= N;i++){
                if(set[i] == i)
                    count++;
            }
            System.out.println(count-1);
        }
    }

    /**
     * 将两个节点连接
     *
     * @param set 并查集数组
     * @param a   节点
     * @param b   节点
     */
    public static void relation(int[] set, int a, int b) {
        int x = find(set, a);
        int y = find(set, b);
        if (x < y)
            set[y] = x;
        else {
            set[x] = y;
        }
    }

    /**
     * 查找a节点的顶头上司,并做一个路径压缩。
     *
     * @param set 并查集数组
     * @param a   节点
     * @return
     */
    public static int find(int[] set, int a) {
        int res = a;
        while (set[res] != res) {
            res = set[res];
        }
        //路径压缩
        while (a != res) {
            int j = set[a];
            set[a] = res;
            a = j;
        }
        return res;
    }
}

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值