题目简单,就简单的三个逻辑,只需要注意个位是从1开始,而不是从0开始输出
题目要求:
让我们用字母B来表示“百”、字母S表示“十”,用“12...n”来表示个位数字n(<10),换个格式来输出任一个不超过3位的正整数。例如234应该被输出为BBSSS1234,因为它有2个“百”、3个“十”、以及个位的4。
输入格式:每个测试输入包含1个测试用例,给出正整数n(<1000)。
输出格式:每个测试用例的输出占一行,用规定的格式输出n。
输入样例1:234输出样例1:
BBSSS1234输入样例2:
23输出样例2:
SS123代码:
#include "stdafx.h"
#include <iostream>
using namespace std;
int main()
{
int n = 0;
cin >> n;
if(n / 100 < 1) //没有百位
{
if( n / 10 < 1) //没有十位
{
for(int i = 1;i<(n+1);i++)
{
cout << i ;
}
}
else //有十位
{
for(int i = 0;i< (n/10);i++)
{
cout << "S";
}
for(int i = 1;i< (n%10+1);i++)
{
cout << i;
}
}
}
else //有百位
{
for(int i = 0;i< (n/100);i++)
{
cout << "B";
}
n = n % 100; //得到十位和个位
for(int i = 0;i< (n/10);i++)
{
cout << "S";
}
for(int i = 1;i< ((n%10)+1);i++)
{
cout << i;
}
}
system("pause");
return 0;
}