NYOJ-24-素数距离问题

描述
现在给出你一些数,要求你写出一个程序,输出这些整数相邻最近的素数,并输出其相距长度。如果左右有等距离长度素数,则输出左侧的值及相应距离。
如果输入的整数本身就是素数,则输出该素数本身,距离输出0

输入
第一行给出测试数据组数N(0< N <=10000)
接下来的N行每行有一个整数M(0< M <1000000),

输出
每行输出两个整数 A B.
其中A表示离相应测试数据最近的素数,B表示其间的距离。

样例输入
3
6
8
10

样例输出
5 1
7 1
11 1

水题,质数检测问题。

//#include <stdio.h>
//#define _MAX 1000100
//int a[_MAX + 1] = {1, 1};   //1表示不是质数,0表示是质数
//int p[_MAX];    //1-1000100的所有质数
//
//int main(int argc, const char * argv[])
//{
//    int N, M;
//    scanf("%d", &N);
//    int key = 0;
//    for (int i = 2; i <= _MAX; i++)
//    {
//        if (!a[i])
//        {
//            p[key++] = i;
//        }
//        for (int j = 0; j < key && i * p[j] <= _MAX; j++)
//        {
//            a[i * p[j]] = 1;
//            if (!(i % p[j]))    //i不是质数,终止循环,减少重复的不必要赋值
//            {
//                break;
//            }
//        }
//    }
//    
//    while (N--)
//    {
//        scanf("%d", &M);
//        if (M == 0 || M == 1)
//        {
//            printf("2 %d\n", 2 - M);
//        }
//        else if (M <= 1000000)
//        {
//            if (!a[M])
//            {
//                printf("%d 0\n", M);
//            }
//            else
//            {
//                int A = 0, B = 0;
//                for (int i = M - 1; i > 0; i--)
//                {
//                    if (!a[i])
//                    {
//                        A = i;
//                        break;
//                    }
//                }
//                for (int j = M + 1; j <= 1000100; j++)
//                {
//                    if (!a[j])
//                    {
//                        B = j;
//                        break;
//                    }
//                }
//                if (M - A > B - M)
//                {
//                    printf("%d %d\n", B, B - M);
//                }
//                else
//                {
//                    printf("%d %d\n", A, M - A);
//                }
//            }
//        }
//    }
//    return 0;
//}

还有一种更好的AC代码。

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int table[1001000] = {1, 1};    //1非质数0质数

int main()
{
    for (int i = 4; i < 1001000; i += 2)
    {
        table[i] = 1;
    }
    for (int i = 3; i <= 1001; i += 2)
    {
        if (!table[i])
        {
            for (int j = i * i; j < 1001000; j += 2 * i)
            {
                table[j] = 1;
            }
        }
    }

    int t, x;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d", &x);
        for (int i = 0; ; i++)
        {
            if (!table[x - i] && x > i)
            {
                printf("%d %d\n", x - i, i);
                break;
            } else if (!table[x + i])
            {
                printf("%d %d\n", x + i, i);
                break;
            }
        }
    }
    return 0;
}

哦啦!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
孪生素数是指两个素数之间的差值为2的素数对。通过筛选法可以找出给定素数范围内的所有孪生素数的组数。 在引用的代码中,使用了递归筛选法来解决孪生素数问题。该程序首先使用循环将素数的倍数标记为非素数,然后再遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 具体实现过程如下: 1. 定义一个数组a[N,用来标记数字是否为素数,其中N为素数范围的上限。 2. 初始化数组a,将0和1标记为非素数。 3. 输入要查询的孪生素数的个数n。 4. 循环n次,每次读入一个要查询的素数范围num。 5. 使用两层循环,外层循环从2遍历到num/2,内层循环从i的平方开始,将素数的倍数标记为非素数。 6. 再次循环遍历素数数组,找出相邻素数之间差值为2的素数对,并统计总数。 7. 输出总数。 至此,我们可以使用这个筛选法的程序来解决孪生素数问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [python用递归筛选法求N以内的孪生质数(孪生素数)](https://blog.csdn.net/weixin_39734646/article/details/110990629)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* *3* [NYOJ-26 孪生素数问题](https://blog.csdn.net/memoryofyck/article/details/52059096)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值