HDU - 4027 Can you answer these queries? (最全的坑点总结)

题目描述:
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6

题意:

给一个序列,有俩种操作,一种是求区间和,一种是将区间每个数开根号后向下取整。  就是一道线段数的题。

坑点:

1.注意:Case #1:有个冒号
2.数据是long long,如果是int会TLE,因为超出int,就是负数,你所有的优化都会失效。
3.注意输入和输出都要用%lld
4.最重要的是他给的区间l和r,l可能会大于r,那么就要先交换位置,最坑的一点,没有之一。

解题思路:

就是一个线段树,但是是开根号,没有办法用延迟更新,但是取根号在6,7次就会到1.
那么我们模拟区间更新,如果父节点的权值和r-l+1相等,那么就不用忘下更新了。因为都是1
具体看代码

代码:

# include <cstdio>
# include <cstring>
# include <cmath>
# define lson l,m,rt << 1
# define rson m + 1,r,rt << 1|1
# define ll long long
using namespace std;

const int maxn = 10000001;

ll sum[maxn<<2];

void PushUp(int rt)
{
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}


void build(int l,int r,int rt)
{
    if(l == r)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    int m = (l+r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void update(int L,int R,int l,int r,int rt)
{
    if(L<= l && r <= R && sum[rt] == (ll)(r-l+1))
    {
        return ;
    }
    if(l == r)
    {
        sum[rt] = sqrt(1.0*sum[rt]);
        return ;
    }
    int m = (l+r) >> 1;
    if(L <= m) update(L,R,lson);
    if(R > m) update(L,R,rson);
    PushUp(rt);
}

ll query(int L,int R,int l,int r,int rt)
{
    if(L<= l && r <= R)
    {
        return sum[rt];
    }
    int m = (l+r) >> 1;
    ll ret = 0;
    if(L <= m) ret += query(L,R,lson);
    if(R > m) ret += query(L,R,rson);
    return ret;
}

int main()
{
    int n,m;
    int f,a,b;
    int ttt = 1;
    while(~scanf("%d",&n))
    {
        printf("Case #%d:\n",ttt++);
        build(1,n,1);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d %d %d",&f,&a,&b);
            if(b < a)
            {
                a = a+b;
                b = a-b;
                a = a-b;
            }
            if(f)  //query
            {
                printf("%lld\n",query(a,b,1,n,1));
            }else{
                update(a,b,1,n,1);
            }
        }
        printf("\n");
    }
    return 0;
} 
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值