Number Sequence(思维题)

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2


思路:我们这样来看这个数列:

1

12

123

1234

12345

..........................

用一个数组len来保存每一个1 to i 的总位数,这样就有了一个递推公式:len[i]=len[i]=len[i-1]+(int)log10(i)+1。(int)log10(i)+1可求i的位数。 

接着,假设求第n位的数字,我们就令i=1; 如果len[i]<n就n-=n-=len[i++],如此循环。  最后问题就转化成了求数列 1 to i 的第n位。

再另i=1,如果(int)log10(i)+1<n就n-=(int)log10(i)+1; i++;继续循环。  问题最终就转化成了求i的第n位数。 剩下的不用说了吧害羞


#include <stdio.h>
#include <math.h>

int len[32000];

int main()
{
    int t,n,i,sum=0;

    for(i=1;sum>=0;i++)
    {
        len[i]=len[i-1]+(int)log10(i)+1;
        sum+=len[i];
    }

    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);

        i=1;
        while(len[i]<n) n-=len[i++];

        i=1;
        while((int)log10(i)+1<n)
        {
            n-=(int)log10(i)+1;
            i++;
        }

        i/=pow(10,(int)log10(i)+1-n);
        i%=10;
        printf("%d\n",i);
    }
}



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值