Description
Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:
x2 = x × x, x3 = x2 × x, x4 = x3 × x, …, x31 = x30 × x.
The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:
x2 = x × x, x3 = x2 × x, x6 = x3 × x3, x7 = x6 × x, x14 = x7 × x7, x15 = x14 × x, x30 = x15 × x15, x31 = x30 × x.
This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:
x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x8 = x4 × x4, x10 = x8 × x2, x20 = x10 × x10, x30 = x20 × x10, x31 = x30 × x.
If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):
x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x16 = x8 × x8, x32 = x16 × x16, x31 = x32 ÷ x.
This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.
Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.
Input
The input is a sequence of one or more lines each containing a single integer n. n is positive and less than or equal to 1000. The end of the input is indicated by a zero.
Output
Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.
Sample Input
1 31 70 91 473 512 811 953 0
Sample Output
0 6 8 9 11 9 13 12
Source
思路:用一个数组存每一次操作之后得到的数,剪下枝,迭代加深即可。详见代码。
#include <stdio.h>
#define max(A,B)(A>B?A:B)
int n,dep,num[15];
bool dfs(int cnt,int x)//x是上一次操作之后得到的最大的数
{
if(num[cnt]==n) return 1;
if(cnt>=dep) return 0;
x=max(x,num[cnt]);
if(x*(1<<(dep-cnt))<n) return 0;//如果最大的数都不能得到n就直接返回
for(int i=0;i<=cnt;i++)
{
num[cnt+1]=num[cnt]+num[i];
if(dfs(cnt+1,x)) return 1;
if(num[cnt]>num[i]) num[cnt+1]=num[cnt]-num[i];
else num[cnt+1]=num[i]-num[cnt];
if(dfs(cnt+1,x)) return 1;
}
return 0;
}
int main()
{
while(~scanf("%d",&n) && n)
{
if(n==1) printf("0\n");
else
{
num[0]=1;
for(dep=1;;dep++)
{
if(dfs(0,1)) break;
}
printf("%d\n",dep);
}
}
}