HDU-3502-Huson's Adventure Island(BFS+状压DP)

Problem Description
A few days ago, Tom was tired of all the PC-games, so he went back to some old FC-games. "Hudson's Adventure Island" was his favorite which he had played thousands of times. But to his disappointed, the more he played, the more he lost. Tom soon gave up the game. 



Now, he invents an easier game on the base of “Hudson's Adventure Island”. He wants to know whether the new game is easy enough. So he came to you for help. 
To simplify the problem, you can assume there is matrix-map contains m(0 < m < 256) rows, n(0 < n < 256) columns, an entrance on the top-left corner (0, 0), an exit on the bottom-right corner (m-1, n-1). Each entry of the matrix contains a integer k.The range of k is defined below:
a)k = 0,it is a free space one can go through.
b)k = -1,it is an obstacle one can’t go through.
c)0 < k < 10000,it is a fruit one can go through and gain k points of energy.
d)k >= 0 at the entrance point and the end point.
At the begin, the hero has 0 points of energy and he can go four directions (up, down, left, right). Each move he makes cost 1 point of energy. No energy no move. If he can’t make a move or get to the exit, he loses the game. The number of fruit is 17 at most.
 

Input
The input consists of multiple test cases. Each test case starts with two positive integers m, n. Then follows m lines, each line contain n integers.
 

Output
For each case, if the hero can get the exit, find and print the maximum points of energy he left. Or print “you loss!”
 

Sample Input
  
  
4 4 8 0 0 0 -1 -1 -1 0 -1 -1 -1 0 0 6 0 0 3 3 4 0 0 0 0 0 0 0 0 4 4 5 0 0 0 0 -1 -1 0 0 -1 -1 0 0 0 0 0
 

Sample Output
  
  
4 0 you loss!
Hint
The hero can pass the exit. When he gets the exit point, he can choose to get out to finish the game or move on to gain more points of energy.
 

Author
imems
 

Source


思路:先用BFS 求出各个水果和终点之间的距离,再用状态压缩DP求解。


#include <cstdio>
#include <queue>
#define INF 999999999
#define max(A,B)(A>B?A:B)
using namespace std;

struct S{
int x,y;
}fruit[20],t;

int n,m,cnt,ans,mp[256][256],dis[20][20],cost[256][256],nxt[4][2]={{1,0},{0,1},{-1,0},{0,-1}},mx[1<<18][20],val[20];

void bfs(S t)
{
    int i,j,nx,ny;

    for(i=0;i<n;i++) for(j=0;j<m;j++) cost[i][j]=INF;

    queue<S>que;

    cost[t.x][t.y]=0;

    que.push(t);

    while(!que.empty())
    {
        t=que.front();

        for(i=0;i<4;i++)
        {
            nx=t.x+nxt[i][0];
            ny=t.y+nxt[i][1];

            if(nx>=0 && nx<n && ny>=0 && ny<m && mp[nx][ny]!=-1 && cost[nx][ny]==INF)
            {
                cost[nx][ny]=cost[t.x][t.y]+1;

                t.x=nx;
                t.y=ny;

                que.push(t);
            }

            t=que.front();
        }

        que.pop();
    }
}

int main()
{
    int i,j;

    while(~scanf("%d%d",&n,&m))
    {
        cnt=0;

        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                scanf("%d",&mp[i][j]);

                if(mp[i][j]>0)
                {
                    fruit[cnt].x=i;
                    fruit[cnt].y=j;

                    val[cnt++]=mp[i][j];
                }
            }
        }

        if(n==1 && m==1)
        {
            if(mp[0][0]>=0) printf("%d\n",mp[0][0]);
            else printf("you loss!\n");

            continue;
        }

        if(mp[0][0]<=0)
        {
            printf("you loss!\n");

            continue;
        }

        if(mp[n-1][m-1]==-1)
        {
            printf("you loss!\n");

            continue;
        }


        fruit[cnt].x=n-1;//终点也放进去
        fruit[cnt].y=m-1;


        for(i=0;i<=cnt;i++)
        {
            bfs(fruit[i]);

            for(j=0;j<=cnt;j++) dis[i][j]=cost[fruit[j].x][fruit[j].y];//各个水果和终点之间的距离

        }


        queue<S>que;

        for(i=1;i<(1<<cnt);i++) for(j=0;j<cnt;j++) mx[i][j]=-1;

        int v;

        t.x=1;
        t.y=0;

        mx[t.x][t.y]=val[0];

        que.push(t);

        while(!que.empty())
        {
            t=que.front();

            for(i=1;i<cnt;i++)
            {
                if(!(t.x & (1<<i)))
                {
                    v=mx[t.x][t.y]-dis[t.y][i];

                    if(v>=0)
                    {
                        t.x=(t.x | (1<<i));
                        t.y=i;

                        if(v+val[i]>mx[t.x][i])
                        {
                            mx[t.x][i]=v+val[i];
                            que.push(t);
                        }

                        t=que.front();
                    }
                }
            }

            que.pop();
        }

        ans=-1;

        for(i=1;i<(1<<cnt);i++) for(j=0;j<cnt;j++) ans=max(ans,mx[i][j]-dis[j][cnt]);

        if(ans>=0) printf("%d\n",ans);
        else puts("you loss!");
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值