eclipse指定运行环境jdk的路径

  • 有时候会有两个eclipse但是需要的jdk版本不同。这时候就需要指定eclipse的版本。

      这个时候就可以不用更改系统环境变量,来更改jdk版本

      可以通过 指定某个eclipse的jdk路径即可:   具体如下示例:

      1  .打开eclipse根目录下的eclipse.ini配置文件   

           

2.  在eclipse.ini 文件中指定位置添加 配置eclipse指定jdk的信息

            

配置完成后保存, 就可以直接启动eclipse了  大功告成!

补充说明: 

eclipse.ini说明文档中特别提到使用-vm参数的注意事项:
(1)The -vm option and its value (the path) must be on separate lines.(-vm选项和其对应的javaw.exe的路径必须各占一行,这应该是参数解析的格式要求)
(2)The value must be the full absolute path to the Java executable, not just to the Java home directory.(指定的虚拟机路径必须是指向可执行Java程序的完整绝对路径,不能只指定到Java_HOME目录。这个好理解,要指定JVM的话肯定要指定到具体的可执行文件去)
(3)The -vm option must occur before the -vmargs option, since everything after -vmargs is passed directly to the JVM.(-vm选项必须放在-vmargs选项前,这是因为-vmargs选项后的值都是作为JVM的参数传给虚拟机的,如果-vm放在-vmargs之后就没有意义了。而-vmargs选项中一般可指定-Xms和-Xmx这两个内存参数)

报错信息解读: 

                            

       code=13   一般是 jdk的位数 和eclipse的位数不一致造成的.

       code=1      我的问题就是  以前安装的jdk(走安装程序 系统中会有注册表一类的东西) 我直接把安装的文件目录剪切到另外一个目录下了  ,虽然后来 又在eclipse.ini文件里配置了新的路径, . 这样做虽然可以让eclipse找到jdk可执行程序的位置,但是 由于jdk路径的改变 (暂且认为系统注册表或是环境变量 还是以前的没有改变) , 导致jdk 自身运行的时候报错.  解决:  重新安装一下jdk即可.  而绿色版(免安装版) 不用担心路径变化的问题.

还有一点就时windows路径分隔符的问题:    

展开阅读全文

没有更多推荐了,返回首页