Number Sequence(hash)

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1
推荐博客:转载:字符串hash总结(hash是一门优雅的暴力!)

hash:

#include <stdio.h>
typedef unsigned long long ull;
int base = 155;
ull po[100010], hs[100010 * 100];
int s1[100010], s2[100010 * 100];
ull solve(int l, int r){
    return hs[r] - hs[l - 1] * po[r - l + 1];
}
int main(){
    po[0] = 1;
    for(int i = 1; i <= 10010; i++)
        po[i] = po[i - 1] * base;
   // freopen("data1.in", "r", stdin);
    int t;
    scanf("%d", &t);
    while(t--){
        int n, m;
        scanf("%d %d", &n, &m);
        ull a1 = 0, pos = 0;
        for(int i = 1; i <= n; i++){
            scanf("%d", &s2[i]);
            hs[i] = hs[i - 1] * base + s2[i];
        }
        for(int i = 1; i <= m; i++){
            scanf("%d", &s1[i]);
            a1 = a1 * base + s1[i];
        }
        for(int i = 1; i <= n; i++){
            if(a1 == solve(i, i + m - 1)){
                pos = i;
                break;
            }
        }
        if(!pos) printf("-1\n");
        else printf("%d\n", pos);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值