IDEA的Maven依赖如何引入到External Libraries中

现象

在用IDEA开发项目中,遇到了一个问题。当在Module的pom.xml中引入依赖:

  <dependency>
      <groupId>com.ctrip.framework.apollo</groupId>
      <artifactId>apollo-client</artifactId>
      <version>0.8.0</version>
    </dependency>
    <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>slf4j-nop</artifactId>
      <version>1.7.21</version>
    </dependency>

并且通过Maven Install命令下载相关的依赖到Maven repository中。
但是,在Class文件中引入相关package时,却报错了。

import com.ctrip.framework.apollo.Config;
import com.ctrip.framework.apollo.ConfigChangeListener;
import com.ctrip.framework.apollo.ConfigService;
import com.ctrip.framework.apollo.model.ConfigChange;
import com.ctrip.framework.apollo.model.ConfigChangeEvent;

都是红色报警状态。且在External Libraries中并未发现相关依赖的Jar包。尝试了一下,发现解决途径也很简单。

解决方法

在IDEA右侧的Maven projects中对应的Module名称上右键,选择Reimport即可更新相关依赖。

阅读更多
文章标签: maven
个人分类: maven
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭