数据结构实验之链表三:链表的逆置
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
输入
输入多个整数,以-1作为结束标志。
输出
输出逆置后的单链表数据。
示例输入
12 56 4 6 55 15 33 62 -1
示例输出
62 33 15 55 6 4 56 12
提示
不得使用数组。
来源
示例程序
//逆置时,设置两个指针,p,q。
//q保存着p的后继,将p依次插入到头结点后面,类似逆序建链表
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *create()
{
int num;
struct node *head,*tail,*p;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
while(~scanf("%d",&num)&&num!=-1)
{
p=(struct node *)malloc(sizeof(struct node));
p->data=num;
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
};
struct node *reverse(struct node* head)
{
struct node *p,*q;
p=head->next;
head->next=NULL;
while(p)
{
q=p->next;
p->next=head->next;
head->next=p;
p=q;
while(q)
q=q->next;
}
return head;
};
int main()
{
struct node *head,*p;
head=create();
head=reverse(head);
p=head->next;
while(p)
{
if(p->next)
printf("%d ",p->data);
else printf("%d\n",p->data);
p=p->next;
}
return 0;
}