poj-1328

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 99975 Accepted: 22202

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <iomanip>
#include <algorithm>
#include <iomanip>
#include <cmath>
using namespace std;
struct node{
    double left,rigth;//我们用来记录每个小岛与x轴相交的左右两点
}num[1005];
bool cmp(node a,node b)
{
    return a.left<=b.left;//每个小岛左坐标按照横坐标从小到大排序
}
int main()
{
    int n,flag,cnt,i,k=1;
    double x,y,d,p;
    while(cin>>n>>d&&n&&d)//输入数据
    {
        flag=1;
        for(i=0;i<n;i++)
        {
            cin>>x>>y;
            if(d<y)//如果该点的纵坐标比雷达半径大,雷达无法覆盖
            {
                flag=0;
                continue;
            }
            num[i].left=x-sqrt(d*d-y*y);//求出以小岛为中心,以雷达半径为半径的圆与x轴相交的左右横坐标
            num[i].rigth=x+sqrt(d*d-y*y);
        }
        if(flag)//如果能够找到能够覆盖点的雷达
        {
            sort(num,num+n,cmp);//从小到大排序
            cnt=1;
            p=num[0].rigth;//第一个雷达的横坐标
            for(i=1;i<n;i++)
            {
                if(num[i].left>p)
                {
                    p=num[i].rigth;//如果该点的左坐标比雷达大,那么雷达无法覆盖,则增加雷达,并把该点的右坐标设定为雷达
                    cnt++;
                }else if(num[i].rigth<p)//如果该点能够被雷达覆盖,但是我们要求出最少的雷达数,我们需要使雷达尽可能的多覆盖,所以要把雷达的位置缩小
                {
                    p=num[i].rigth;
                }
            }
            cout<<"Case "<<k++<<": "<<cnt<<endl;
        }
        else{//雷达不能全部覆盖
            cout<<"Case "<<k++<<": "<<"-1"<<endl;
        }
        //cout<<"Case "<<k++<<": "<<cnt<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值