数据结构实验之链表四:有序链表的归并

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100




建立两个链表
释放一个表头,用另一个作为新表头

 源代码C#
<span style="font-size:14px;">#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *create(int n)
{
    struct node*head,*p,*tail;
    int i;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->next=NULL;
        scanf("%d",&p->data);
        tail->next=p;
        tail=p;
    }
    return (head);
};
void print(struct node *h)
{
    struct node *p=h->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            printf("%d",p->data);
        else
            printf("%d ",p->data);
        p=p->next;
    }
}
struct node *pai(struct node *h1,struct node *h2)
{
    struct node *p=h1->next;
    struct node *q=h2->next;
    struct node *tail;
    h1->next=NULL;
    tail=h1;
    free(h2);
    while(p&&q)
    {
        if(p->data<q->data)
        {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
    }
    while(p)
    {
        tail->next=p;
        tail=p;
        p=p->next;
        tail->next=NULL;
    }
    while(q)
    {
        tail->next=q;
        tail=q;
        q=q->next;
        tail->next=NULL;
    }

    return (h1);
}
int main()
{
    int m,n;
    char a[10];
    scanf("%d %d",&m,&n);
    struct node *p,*q,*w;
    p=create(m);
    gets(a);
    q=create(n);
    w=pai(p,q);
    print(w);
    return 0;
}</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值