PTA-是否同一棵二叉搜索树

给定一个插入序列就可以唯一确定一棵二叉搜索树。然而,一棵给定的二叉搜索树却可以由多种不同的插入序列得到。例如分别按照序列{2, 1, 3}和{2, 3, 1}插入初始为空的二叉搜索树,都得到一样的结果。于是对于输入的各种插入序列,你需要判断它们是否能生成一样的二叉搜索树。

输入格式:

输入包含若干组测试数据。每组数据的第1行给出两个正整数NN (\le 1010)和LL,分别是每个序列插入元素的个数和需要检查的序列个数。第2行给出NN个以空格分隔的正整数,作为初始插入序列。最后LL行,每行给出NN个插入的元素,属于LL个需要检查的序列。

简单起见,我们保证每个插入序列都是1到NN的一个排列。当读到NN为0时,标志输入结束,这组数据不要处理。

输出格式:

对每一组需要检查的序列,如果其生成的二叉搜索树跟对应的初始序列生成的一样,输出“Yes”,否则输出“No”。

输入样例:

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

输出样例:

Yes
No
No

简单的排序树问题,不难想到

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
using namespace std;
struct node{
	int data;
	struct node *L,*R;
	node(){
		L = R = NULL;
	}
};
int n,m;
struct node *Create(struct node *root,int key){
	if(root==NULL){
		root = new node();
		root->data = key;
	}
	else{
		if(root->data>=key)
			root->L = Create(root->L,key);
		else
			root->R = Create(root->R,key);
	}
	return root;
}
int judge(struct node *root1,struct node *root2){
	if(root1 == NULL && root2 == NULL)
		return 1;
	else if(root1!=NULL && root2 !=NULL){
		if(root1->data == root2->data)
			if(judge(root1->L,root2->L) && judge(root1->R,root2->R))
				return 1;
	}
	return 0;
}
int main(){
	while(~scanf("%d",&n) && n){
		scanf("%d",&m);
		struct node *root1,*root2;
		root1 = NULL;
		int x;
		for(int i = 0; i < n; i++){
			scanf("%d",&x);
			root1 = Create(root1,x);
		}
		while(m--){
			root2 = NULL;
			for(int i = 0; i < n; i++){
				scanf("%d",&x);
				root2 = Create(root2,x);
			}
			if(judge(root1,root2))
				printf("Yes\n");
			else
				printf("No\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值