小希的迷宫
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 66 Accepted Submission(s) : 27
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
整个文件以两个-1结尾。
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Yes
Yes
No
#include<iostream>
using namespace std;
const int maxn=100000+10;
int sign[maxn];
int rank[maxn];
int father[maxn];
int mark[maxn];
void make_set(int x)
{
father[x]=x;
rank[x]=0;
}
int find_set(int x)
{
if(father[x]!=x)
{
father[x]=find_set(father[x]);
}
return father[x];
}
int Union(int x,int y)
{
x=find_set(x);
y=find_set(y);
if(x == y)
return 1;
else if(rank[x] > rank[y])
{
father[y]=x;
}
else if(rank[x] < rank[y])
{
father[x]=y;
}
else if(rank[x] == rank[y])
{
father[y]=x;
rank[y]++;
}
return 0;
}
int main()
{
int x,y;
int i,j;
while(cin>>x>>y)
{
int flag=0;
if(x<0 && y<0)
{
break;
}
memset(mark,0,sizeof(mark));
for(i=1;i<=maxn;i++)
{
make_set(i);
}
while(x && y)
{
if(!flag)
{
flag=Union(x,y);
mark[x]=1;//点不是一定按顺序,比如如果不输入1也可以,所以要给输入的点标记一下
mark[y]=1;//
}
cin>>x>>y;
}
if(flag)
{
cout<<"No"<<endl;
}
else
{
int count=-1;
for(int k=1;k<=maxn;k++)//
{
if(father[k]==k && mark[k])//
{
count++;
}
}
if(count==-1 || count==0)
{
cout<<"Yes"<<endl;
}
else
cout<<"No"<<endl;
}
}
return 0;
}
/*错误 没有标记点
int main()
{
int x,y;
int i,j;
while(cin>>x>>y)
{
int flag=0;
if(x<0 && y<0)
{
break;
}
for(i=1;i<=maxn;i++)
{
make_set(i);
}
while(x && y)
{
if(!flag)
{
flag=Union(x,y);
}
cin>>x>>y;
}
if(flag)
{
cout<<"No"<<endl;
}
else
cout<<"Yes"<<endl;
}
return 0;
}*/