设计与算法:Radar Installation

描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

英文不太会,看老师的讲解做的

在输出时空格的错误使我多提交了4遍,总算过了啊        

//Writed by Wangzhimin Date:2023/11/28 

//以岛屿为中心做圆,它和x轴的的交点是一个区间,区间上有相同点时 
//以相同的点在x轴上做圆,就会包含有相同点的岛屿 
//把岛屿换成x轴上的区间,按左点排序(小),如果区间无相同点,即左点大于 
//前一区间的右点 ,雷达加1.
//看老师是这样讲的 
//问题主要是解法重要啊 
#include<bits/stdc++.h>
using namespace std;
struct radar{//存区间的左点和右点,及排序法 
    double l;
    double r;
    bool operator < (const radar & r)
    {
        return l<r.l;
    }
}radars[1005];
int main()
{
    int n,d,i,x,y,sum=1;
    while(scanf("%d%d",&n,&d))
    {
        if(n==0)break;
        int flag=1,rad=1;//雷达有1个 
        double xx;
        for(i=0;i<n;i++)//输入n个组数 
        {
            scanf("%d%d",&x,&y);
            if(y>d)
            flag=0;//如果y值比d值大,和x轴没交点
            xx=sqrt(d*d-y*y);
            radars[i].l=x-xx;//放置区间 
            radars[i].r=x+xx;
        }
        if(flag==0)
        {
            printf("Case %d: -1\n",sum++);
            continue;
            }
        sort(radars,radars+n);//排序 
        double ll=radars[0].l;//取初值 
        double rr=radars[0].r;
        for(i=1;i<n;i++)
        {
            if(radars[i].l>rr)//如果左点大于求得的右点 
            {
                rad++;
                ll=radars[i].l;//重置 
                rr=radars[i].r;
            }
            else
            {
                       rr=min(radars[i].r,rr);//因为左点是增大,没考虑,右点如果小,就往前缩 
            }
        }
            
            printf("Case %d: %d\n",sum++,rad);
    }

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值