sdau 省赛热身4 C - Counting Pair

sdau 省赛热身4   C - Counting Pair      

C - Counting Pair
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld & %llu

Description


Bob hosts a party and invites N boys and M girls. He gives every boy here a unique number Ni(1 <= Ni <= N). And for the girl, everyone holds a unique number Mi(1 <= Mi <= M), too.

Now when Bob name a number X, if a boy and a girl wants and their numbers' sum equals to X, they can get in pair and dance.

At this night, Bob will name Q numbers, and wants to know the maxinum pairs could dance in each time. Can you help him?

Input



First line of the input is a single integer T(1 <= T <= 30), indicating there are T test cases.

The first line of each test case contains two numbers N and M(1 <= N,M <= 100000).

The second line contains a single number Q(1 <= Q <= 100000).

Each of the next Q lines contains one number X(0 <= X <= 10^9), indicating the number Bob names.

Output

For each test case, print "Case #t:" first, in which t is the number of the test case starting from 1.

Then for each number Bob names, output a single num in each line, which shows the maxinum pairs that could dance together.

Sample Input

1
4 5
3
1
2
3

Sample Output

Case #1:
0
1
2

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.


数字组合

题目大意:一个party来了n男m女,每人有其对应(1~n)或(1~m)编号,主人给出一数,若男女两队人马中有两数之和等于此数,则可配对,问给出一数,可配多少对。

题目分析:若给出的数x既小于m,又小于n,则x-1就是答案。eg.在本例第三个数据中3可配1~2和2~1两对。但如果给出的数-1大于m,n之一,就出现问题了,组合往上找的时候会meet上界,这时需要把上界之上的部分减掉。(这部分代码挺绕的,不过多看两眼肯定能明白)

code:

#include<stdio.h>
int main()
{
	int i,j,t,n,m,p,count,k,l,test;
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		scanf("%d%d%d",&n,&m,&p);
		printf("Case #%d:\n",i);
		for(j=0;j<p;j++)
		{
			count=0;
			scanf("%d",&test);
			/*test--;
			for(k=1;k<=n;k++)
			{
				if(test-k>0&&test-k<=m)count++;
				else if(test-k<=0)break;
			}
			printf("%d\n",count);*/
			if(test-1<=n&&test-1<=m)printf("%d\n",test-1);
			else if(test>n+m)printf("0\n");
			else printf("%d\n",test-1-(test>n?test-1-n:0)-(test>m?test-1-m:0));
		}
	}
}
PS:今天状态尚可,A出三道,后面还有一道。(continue praying)




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值