hdu 5384 Danganronpa 2015多校联合训练赛#8 ac自动机

Danganronpa 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 171    Accepted Submission(s): 83


Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are  n  verbal evidences, and Stilwell has  m  "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings  Ai , and bullets are some strings  Bj . The damage to verbal evidence  Ai  from the bullet  Bj  is  f(Ai,Bj) .
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words,  f(A,B)  is equal to the times that string  B  appears as a substring in string  A .
For example:  f(ababa,ab)=2 f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence  Ai  after shooting all  m  bullets  Bj , in other words is  mj=1f(Ai,Bj) .
 

Input
The first line of the input contains a single number  T , the number of test cases.
For each test case, the first line contains two integers  n m .
Next  n  lines, each line contains a string  Ai , describing a verbal evidence.
Next  m  lines, each line contains a string  Bj , describing a bullet.

T10
For each test case,  n,m105 1|Ai|,|Bj|104 |Ai|105 |Bj|105
For all test case,  |Ai|6105 |Bj|6105 Ai  and  Bj  consist of only lowercase English letters
 

Output
For each test case, output  n  lines, each line contains a integer describing the total damage of  Ai  from all  m  bullets,  mj=1f(Ai,Bj) .
 

Sample Input
  
  
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

Sample Output
  
  
1 1 0 3 7
 

Source


对所有单词建立ac自动机。然后跑一边就完事了。


#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
#define ll long long
struct Node{
    Node*ch[27],*fail;
    int mark,id;
}word[600001];//´æ×ÖµäÊ÷
int cnt;
Node *super,*root;//
Node*newNode(){//²åÈë×Ö·û´®
    memset(&word[cnt],0,sizeof(word[0]));
    word[cnt].id = cnt;
    return &word[cnt++];
}
void insert(Node*root,char*s){//½¨Ê÷
    if(*s==0){
        root->mark++;
        return;
    }
    int id = *s-'a';
    if(root->ch[id] == 0)
        root->ch[id] = newNode();
    insert(root->ch[id],s+1);
}
void build(Node*root){//
    for(int i = 0;i < 27;i++)
        super->ch[i] = root;
    root->fail = super;
    queue<Node*>Q;
    Q.push(root);
    while(!Q.empty()){
        Node* q = Q.front();
        Q.pop();
        for(int i = 0;i < 27; i++){
            if(q->ch[i] != NULL){
                Q.push(q->ch[i]);
                q->ch[i]->fail = q->fail->ch[i];
                q->ch[i]->mark += q->fail->ch[i]->mark;
            }
            else q->ch[i] = q->fail->ch[i];
        }
    }
}
ll autofind(char *s){
    ll ans = 0,id;
    Node*rt = root,*p;
    while(*s){
        id = *s - 'a';
        if(rt->ch[id] != root) rt = rt->ch[id];
        else{
            while(rt != root && rt->ch[id] == root)
            	rt = rt->fail;
        }
        ans += rt->mark;
        s++;
        if(*s == 'a'+26){
            printf("%I64d\n",ans);
            ans = 0;
        }
    }
    return ans;
}

char sen[400007];
char wor[400007];
int main(){
    int t,n,m;
    scanf("%d",&t);
    while(t--){
        cnt = 0;
        scanf("%d%d",&n,&m);
        int len = 0,lex;
        for(int i = 0;i < n; i++){
            scanf("%s",sen+len);
            lex = strlen(sen+len);
            len += lex;
            sen[len] = 'a'+26;
            len++;
        }
        sen[len] = '\0';

        super = newNode();
        root = newNode();
        for(int i = 0;i < m; i++){
            scanf("%s",wor);
            insert(root,wor);
        }
        build(root);
        ll ans = autofind(sen);

        //printf("%I64d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值