hdu 5486 Difference of Clustering 2015多校联合训练赛

Difference of Clustering

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 320    Accepted Submission(s): 112


Problem Description
Given two clustering algorithms, the old and the new, you want to find the difference between their results.
A clustering algorithm takes many member entities as input and partition them into clusters . In this problem, a member entity must be clustered into exactly one cluster. However, we don’t have any pre-knowledge of the clusters, so different algorithms may produce different number of clusters as well as different cluster IDs. One thing we are sure about is that the memberIDs are stable, which means that the same member ID across different algorithms indicates the same member entity.
To compare two clustering algorithms, we care about three kinds of relationship between the old clusters and the new clusters: split, merge and 1:1. Please refer to the figure below.

Let’s explain them with examples. Say in the old result, m0, m1, m2 are clustered into one cluster c0, but in the new result, m0 and m1 are clustered into c0, but m2 alone is clustered into c1. We denote the relationship like the following:
●  In the old, c0 = [m0, m1, m2]
●  In the new, c0 = [m0, m1], c1 = [m2]
There is no other members in the new c0 and c1. Then we say the old c0 is split into new c0 and new c1. A few more examples:
●  In the old, c0 = [m0, m1, m2]
●  In the new, c0 = [m0, m1, m2].
This is 1:1.
●  In the old, c0 = [m0, m1], c1 = [m2]
●  In the new, c0 = [m0, m1, m2]
This is merge. Please note, besides these relationship, there is another kind called “n:n”:
●  In the old, c0 = [m0, m1], c1 = [m2, m3]
●  In the new, c0 = [m0, m1, m2], c1 = [m3]
We don’t care about n:n.
In this problem, we will give you two sets of clustering results, each describing the old and the new. We want to know the total number of splits, merges, and 1:1 respectively.

 

Input
The first line of input contains a number T indicating the number of test cases ( T100 ).
Each test case starts with a line containing an integer N indicating the number of member entities ( 0N106 ). In the following N lines, the i -th line contains two integers c1 and c2, which means that the member entity with ID i is partitioned into cluster c1 and cluster c2 by the old algorithm and the new algorithm respectively. The cluster IDs c1 and c2 can always fit into a 32-bit signed integer.
 

Output
For each test case, output a single line consisting of “Case #X: A B C”. X is the test case number starting from 1. A , B , and C are the numbers of splits, merges, and 1:1s.
 

Sample Input
  
  
2 3 0 0 0 0 0 1 4 0 0 0 0 1 1 1 1
 

Sample Output
  
  
Case #1: 1 0 0 Case #2: 0 0 2
 

Source


#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<cstdio>
using namespace std;

map<int,int> haha;
map<int,int> hehe;
struct Node{
    int old,ne;
};
#define maxn 1100007
int num[maxn];
int num2[maxn];
Node po[maxn];
int comp1(Node a,Node b){
    return a.old < b.old;
}
int comp2(Node a,Node b){
    return a.ne < b.ne;
}

int main(){
    int t,tt=1,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i = 0;i <= n; i++)
            num[i] = num2[i]= 0;
        int cnt = 0;
        haha.clear();
        hehe.clear();
        int cnt2 = 0;
        for(int i = 0;i < n; i++){
            scanf("%d%d",&po[i].old,&po[i].ne);
            if(haha.find(po[i].old) == haha.end())
                haha[po[i].old] = cnt++;
            po[i].old = haha[po[i].old];
            num[po[i].old]++;

            if(hehe.find(po[i].ne) == hehe.end())
                hehe[po[i].ne] = cnt2++;
            po[i].ne = hehe[po[i].ne];
            num2[po[i].ne]++;
        }
        int ans1=0,ans2=0,ans3=0;
        sort(po,po+n,comp1);
        int x = 0;
        while(x < n){
            int y = x;
            haha.clear();
            while(po[y].old == po[x].old && y < n)
                y++;
            int ch = po[x].ne, xn=0;
            for(int i = x; i < y; i++){
                if(haha.find(po[i].ne) == haha.end())
                    haha[po[i].ne] = 0;
                haha[po[i].ne]++;
            }
            int flag = 1;
            map<int,int>::iterator it = haha.begin();
            while(it != haha.end()){
                if(it->second != num2[it->first])
                    flag = 0;
                it++;
            }
            if(haha.size() > 1 && flag == 1)ans1+=flag;
            x = y;
        }

        sort(po,po+n,comp2);
        x = 0;
        while(x < n){
            int y = x;
            haha.clear();
            while(po[y].ne == po[x].ne && y < n)
                y++;
            int ch = po[x].old, xn = 0;
            for(int i = x;i < y; i++){
                if(haha.find(po[i].old) == haha.end())
                    haha[po[i].old] = 0;
                haha[po[i].old]++;
            }
            int flag = 1;
            map<int,int>::iterator it = haha.begin();
            while(it != haha.end()){
                if(it->second != num[it->first])
                    flag = 0;
                it++;
            }
            if(flag == 1){
                if(haha.size() > 1) ans2++;
                else ans3++;
            }
            x = y;
        }
        printf("Case #%d: %d %d %d\n",tt++,ans1,ans2,ans3);
    }
    return 0;
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值