hdu 5427 A problem of sorting 排序

A problem of sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1044    Accepted Submission(s): 438


Problem Description
There are many people's name and birth in a list.Your task is to print the name from young to old.(There is no pair of two has the same age.)


 

Input
First line contains a single integer  T100  which denotes the number of test cases. 

For each test case, there is an positive integer  n(1n100)  which denotes the number of people,and next  n  lines,each line has a name and a birth's year(1900-2015) separated by one space.

The length of name is positive and not larger than  100 .Notice name only contain letter(s),digit(s) and space(s).
 

Output
For each case, output  n  lines.
 

Sample Input
  
  
2 1 FancyCoder 1996 2 FancyCoder 1996 xyz111 1997
 

Sample Output
  
  
FancyCoder xyz111 FancyCoder
 

Source



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define maxn 101
int year[maxn],num[maxn];
char name[maxn][107];


int comp(int a,int b){
    return year[a] > year[b];
};

int main(){
    int t, n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        getchar();
        for(int i= 0;i <n ; i++){
            num[i] = i;
            int len = 0;
            while(1){
                name[i][len] = getchar();
                if(name[i][len] == '\n') break;
                len++;
            }
            name[i][len-5]= '\0';
            year[i] = 0;
            for(int j = len-4;j < len; j++)
                year[i] = year[i]*10+name[i][j]-'0';
        }
        sort(num,num+n,comp);
        for(int i = 0;i < n; i++){
            printf("%s\n",name[num[i]]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值