hdu 5464 Clarke and problem 动态规划

Clarke and problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 844    Accepted Submission(s): 340


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a student and read a book.
Suddenly, a difficult problem appears: 
You are given a sequence of number  a1,a2,...,an  and a number  p . Count the number of the way to choose some of number(choose none of them is also a solution) from the sequence that sum of the numbers is a multiple of  p ( 0  is also count as a multiple of  p ). Since the answer is very large, you only need to output the answer modulo  109+7
 

Input
The first line contains one integer  T(1T10)  - the number of test cases. 
T  test cases follow. 
The first line contains two positive integers  n,p(1n,p1000)  
The second line contains  n  integers  a1,a2,...an(|ai|109 ).
 

Output
For each testcase print a integer, the answer.
 

Sample Input
  
  
1 2 3 1 2
 

Sample Output
  
  
2 Hint: 2 choice: choose none and choose all.
 

Source
 


定义dp[i][j]表示前i个数字构成的所有集合中,集合内所有数字相加之和对p取模为j的集合的个数。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
int dp[2][1001];
#define mod 1000000007
int main(){
    int t,n,p;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&p);
        int w, u = 0, v = 1;
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        for(int i = 0;i < n; i++){
            scanf("%d",&w);
            for(int j = 0;j < p; j++)
                dp[v][j] = dp[u][j];
            w %= p;
            if(w < 0) w+=p;
            for(int j = 0;j < p ;j++){
                dp[v][w] += dp[u][j];
                if(dp[v][w] >= mod) dp[v][w] -= mod;
                w++;
                if(w >= p) w -= p;
            }
            swap(u,v);
        }
        printf("%d\n",dp[u][0]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值