hdu 5428 The Factor 找质因子


The Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1827    Accepted Submission(s): 551


Problem Description
There is a sequence of  n  positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead. 
 

Input
The first line contains one integer  T (1T15) , which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains one integer denoting the value of  n (1n100) .

2. The second line contains  n  integers  a1,,an (1a1,,an2×109) , which denote these  n  positive integers. 
 

Output
Print  T  answers in  T  lines.
 

Sample Input
  
  
2 3 1 2 3 5 6 6 6 6 6
 

Sample Output
  
  
6 4
 

Source



求最小的两个质因子乘积即可

<span style="font-family: Arial, Helvetica, sans-serif;">#include<iostream></span>#include<cstdio>
#include<map>
using namespace std;
#define ll long long
ll inf = 100000000007ll;
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        ll u;
        ll x1=inf,x2=inf;
        for(int j = 0;j < n; j++){
            scanf("%lld",&u);
            for(ll i = 2;i * i <= u; i++){
                while(u % i == 0){
                    if(i < x1) x2 = x1, x1 = i;
                    else if(i < x2) x2 = i;
                    u /= i;
                }
            }
            if(u != 1){
                if(u < x1) x2 = x1, x1 = u;
                else if(u < x2) x2 = u;
            }
        }
        if(x2 == inf) printf("-1\n");
        else printf("%lld\n",x1*x2);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值