poj 3255 Roadblocks——dijkstra次短路径

Roadblocks
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

题意: 某街区共有R条道路、N个路口。道路可以双向通行。问1号路口到N号路口的次短路长度是多少?同一条边可以经过多次。

题解: 到某个顶点v的次短路要么是到其他顶点u的最短路再加上u → \rightarrow v的边,要么是到u的次短路再加上u → \rightarrow v的边,因此所需要求的就是到所有顶点的最短路径和次短路。因此,对于每个顶点,我们记录的不仅仅是最短路径,还有次短路径。接下去只要用Dijkstra算法相同的做法,不断更新这两个距离就可以求出次短路径了。

c++ AC 代码

#include<iostream>
#include<queue>
#include<algorithm>
#include<vector>

#define MAX_N 100010
#define INF 0x3f3f3f3f
using namespace std;

struct edge
{
	int to, cost;
};

typedef pair<int, int> P;

int main()
{
	int N, R;
	vector<edge> G[MAX_N];
	int dist[MAX_N];
	int dist2[MAX_N];
	priority_queue<P, vector<P>, greater<P> > que;
	
	while(cin >> N >> R)
	{
		for(int i=0; i<R; i++)
		{
			int u, v, cost;
			cin >> u >> v >> cost;
			u -= 1; v -= 1;
			G[u].push_back({v,cost});	// 因为边可以重复走,所有这里把两个对应有连接的点分别加一次
			G[v].push_back({u,cost});
		}
		
		fill(dist,dist+N,INF);
		fill(dist2,dist2+N,INF);
		dist[0] = 0;
		que.push(P(0,0));
		
		while(!que.empty())	// dijkstra 算法 优先队列版
		{
			P p = que.top();
			que.pop();
			int v = p.second, d = p.first;
			if(dist2[v] < d) continue;
			
			for(int i=0;i<G[v].size();i++)
			{
				edge &e = G[v][i];
				int d2 = d + e.cost;
				if(dist[e.to] > d2)		// 求最短路
				{
					swap(dist[e.to],d2);
					que.push(P(dist[e.to], e.to));
				}
				
				if(dist2[e.to] > d2 && dist[e.to] < d2)		// 求次短路
				{
					dist2[e.to] = d2;
					que.push(P(dist2[e.to], e.to));
				}
			}
		}
		cout << dist2[N-1] << endl;
	}
	return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值