poj 2503 Babelfish——字典映射

Babelfish
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.

Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint

Huge input and output,scanf and printf are recommended.

题意: 根据给出的词典对应关系,将下面输入的词翻译成英文词汇。

题解: 字典映射,输入的处理麻烦一点,题目本身不难

c++ AC 代码

#include <map>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1e3 + 10;

int N, K;
string arr[maxn];
int cnt = 0;

int main()
{
	char s1[15], s2[15], s[15];
	map<string, string> dict;
	while (1)
	{
		char c;

		if ((c = getchar()) == '\n')
			break;
		else
		{
			s1[0] = c;
			int i = 1;
			while (1)
			{
				c = getchar();
				if (c == ' ')
				{
					s1[i] = '\0';
					break;
				}
				else
					s1[i++] = c;
			}
		}

		cin >> s2;
		getchar();

		dict[s2] = s1;
	}

	while (cin >> s)
	{
		if (dict[s].empty())
			puts("eh");
		else
			cout << dict[s] << endl;
	}
	// system("pause");
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值