本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。
函数接口定义:
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:
struct stud_node {
int num; /*学号*/
char name[20]; /*姓名*/
int score; /*成绩*/
struct stud_node *next; /*指向下个结点的指针*/
};
输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。
函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct stud_node {
int num;
char name[20];
int score;
struct stud_node *next;
};
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
int main()
{
int min_score;
struct stud_node *p, *head = NULL;
head = createlist();
scanf("%d", &min_score);
head = deletelist(head, min_score);
for ( p = head; p != NULL; p = p->next )
printf("%d %s %d\n", p->num, p->name, p->score);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80
输出样例:
2 wang 80
4 zhao 85
题目集全集传送门
struct stud_node* createlist()
{
int num;
struct stud_node* head = NULL, * tail = NULL, * p = NULL;
scanf("%d", &num);
while (num)
{
p = (struct stud_node*)malloc(sizeof(struct stud_node));
p->num = num;
scanf("%s %d", p->name, &p->score);
p->next = NULL;
if (head == NULL)
head = p;
else
tail->next = p;
tail = p;
scanf("%d", &num);
}
return head;
}
struct stud_node* deletelist(struct stud_node* head, int min_score)
{
struct stud_node* ptr1, * ptr2;
/*要被删除的是表头结点*/
while (head != NULL && head->score < min_score)
{
ptr2 = head;
head = head->next;
free(ptr2);
}
if (head == NULL) //空链表
return NULL;
/*要被删除的是非表头结点*/
ptr1 = head;
ptr2 = head->next;//从表头的下一个结点搜索所有符合删除要求的结点
while (ptr2 != NULL)
{
if (ptr2->score < min_score)//ptr2所指结点符合删除要求
{
ptr1->next = ptr2->next;
free(ptr2);
}
else
ptr1 = ptr2;//ptr1后移一个结点
ptr2 = ptr1->next;//ptr2指向ptr1的后一个结点
}
return head;
}