L1-064 估值一亿的AI核心代码 (20 分)(Python版,使用正则表达式)

在这里插入图片描述
以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。

输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

Level-1答案传送门

import re

for i in range(int(input())):
    words = input()
    print(words)
    print('AI: ', end='')
    words = words.strip()  # 去除首尾空格
    words = re.sub(' +', ' ', words)  # 如果有多个空格,则替换为一个空格
    words = re.sub(' +(\\W)', '\\1', words)  # 去除标点符号前的空格,\\1代表前面有捕获的分组的表达式即用()括起来的匹配,即前面括号中的内容
    words = re.sub('\?', '!', words)  # 将?替换为!
    
    for alphabet in words:
        if alphabet != 'I':
            words = words.replace(alphabet, alphabet.lower())  # 除'I'之外,将大写转换为小写
    # 题目上先换的can you、could you,然后才换的I、me
    # 并且题目要求输出I can、I could才行
    # 所以暂时先将can you,could you,I、me分别用AAA,BBB,CCC代替
    words = re.sub('\\bcan you\\b', 'AAA', words)
    words = re.sub('\\bcould you\\b', 'BBB', words)
    words = re.sub('\\b(I|me)\\b', 'CCC', words)
    # 再将AAA,BBB,CCC相应的换回来
    words = re.sub('AAA', 'I can', words)
    words = re.sub('BBB', 'I could', words)
    words = re.sub('CCC', 'you', words)

    print(words)
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Re:从零开始的代码生活

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值