九度OJ1444:More is better

题目描述:

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入:

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出:

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
样例输出:
4
2
#include<iostream>
#include<cstdio>
 
using namespace std;
#define N 10000001
int Tree[N];
 
int findRoot(int x)
{
    if(Tree[x] == -1){
        return x;
    }
    else{
        int tmp = findRoot(Tree[x]);
        Tree[x] = tmp;
        return tmp;
    }
}
int sum[N];
int main()
{
    int n, a, b;
    //int sum[N]; 
    while(scanf("%d", &n) != EOF){
        for(int i = 0; i < N; i++){
            Tree[i] = -1;
            sum[i] = 1;
        }
        while(n--){
            scanf("%d %d", &a, &b);
            int ra = findRoot(a);
            int rb = findRoot(b);
 
            if(ra != rb){
                sum[rb] += sum[ra];
                Tree[ra] = rb;
            }
        }
        int ans = 1;
        for(int i = 1; i < N; i++){
            if(Tree[i] == -1 && sum[i] > ans)
                ans = sum[i];
        }
 
        printf("%d\n", ans);
    }
 
    return 0;
}
 
/**************************************************************
    Problem: 1444
    User: various
    Language: C++
    Result: Accepted
    Time:970 ms
    Memory:79644 kb
****************************************************************/

 
 
当我把int sum[N];放在main函数里会出现RE,,暂时不知道为什么,如果有哪位大神知道,可否联系下我,谢谢!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值