Uva11300 - Spreading the Wealth

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

看到第六面例题三理解了很久,书上的问题从前n-1个方程可以推导出最后一个方程,应该可以从这两方面理解:1,直接推出来。An-1 - Xn-1 + Xn = M ==> Xn = M - An-1 +Xn-1
An - Xn + x1 = An - M + An-1 - Xn-1 + x1
=An+An-1 - M - Xn-1 + x1
同理最后得到:An+An-1+...+A1 - (n-1)*M - X1 + X1 = M
2,通过理解,因为移动之后是前面n-1人满足每个人拿到M金币的,共(n-1)*M币,所以最后一个人理所当然剩余M了.
我们希望移动最少金币也就是说|X1| + |X2| +...+|Xn|最小,而Xn = X1 - Cn-1;
所以就是|X1| + |X1-C1| +...+|X1 - Cn-1|取最小。变成了“中位数”的问题
因为这里是实际情况只能在人选取中位数x1 = C[n/2](偶数点靠右) 或者 x1 = C[(n-1)/2] (偶数点靠左)都是可以的。

看到第六面例题三理解了很久,书上的问题从前n-1个方程可以推导出最后一个方程,应该可以从这两方面理解:1,直接推出来。An-1 - Xn-1 + Xn = M ==> Xn = M - An-1 +Xn-1
An - Xn + x1 = An - M + An-1 - Xn-1 + x1
                    =An+An-1 - M - Xn-1 + x1
同理最后得到:An+An-1+...+A1 - (n-1)*M - X1 + X1 = M
2,通过理解,因为移动之后是前面n-1人满足每个人拿到M金币的,共(n-1)*M币,所以最后一个人理所当然剩余M了.
我们希望移动最少金币也就是说|X1| + |X2| +...+|Xn|最小,而Xn = X1 - Cn-1;
所以就是|X1| + |X1-C1| +...+|X1 - Cn-1|取最小。变成了“中位数”的问题
因为这里是实际情况只能在人选取中位数x1 = C[n/2](偶数点靠右) 或者 x1 = C[(n-1)/2] (偶数点靠左)都是可以的。
看到第六面例题三理解了很久,书上的问题从前n-1个方程可以推导出最后一个方程,应该可以从这两方面理解:1,直接推出来。An-1 - Xn-1 + Xn = M ==> Xn = M - An-1 +Xn-1
An - Xn + x1 = An - M + An-1 - Xn-1 + x1
                    =An+An-1 - M - Xn-1 + x1
同理最后得到:An+An-1+...+A1 - (n-1)*M - X1 + X1 = M
2,通过理解,因为移动之后是前面n-1人满足每个人拿到M金币的,共(n-1)*M币,所以最后一个人理所当然剩余M了.
我们希望移动最少金币也就是说|X1| + |X2| +...+|Xn|最小,而Xn = X1 - Cn-1;
所以就是|X1| + |X1-C1| +...+|X1 - Cn-1|取最小。变成了“中位数”的问题
因为这里是实际情况只能在人选取中位数x1 = C[n/2](偶数点靠右) 或者 x1 = C[(n-1)/2] (偶数点靠左)都是可以的。

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int MAXN = 1000010;
int n;
long long  C[MAXN], avg;
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        avg = 0;
        for(i=1; i<=n; i++)
        {  
                 scanf("%lld",&C[i]);
                 avg+=C[i];
        }
        C[0] = 0;
        avg/=n;
        for(i=1; i<n; i++)
        {
                 C[i] = C[i-1] + C[i] - avg;
        }
        sort(C,C+n);
        long long ans = 0, x1 = C[(n-1)/2];
        for(i=0; i<n; i++)
        {
                 ans += abs(C[i] - x1);
        }
        printf("%lld\n", ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值