【字符串 Hash】【DP】 HDU - 5763 Another Meaning【串二可用第二种意思替换,问串一这句话可能有几种含义】

【字符串 Hash】【DP】 HDU - 5763 Another Meaning【串二可用第二种意思替换,问串一这句话可能有几种含义】

As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”.
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.

Sample Input
4
hehehe
hehe
woquxizaolehehe
woquxizaole
hehehehe
hehe
owoadiuhzgneninougur
iehiehieh

Sample Output
Case #1: 3
Case #2: 2
Case #3: 5
Case #4: 1

Hint
In the first case, “ hehehe” can have 3 meaings: “he”, “he”, “hehehe”.
In the third case, “hehehehe” can have 5 meaings: “hehe”, “he*he”, “hehe”, “**”, “hehehehe”.

题意:

str1是一句话,str2可以被别的意思替换,(比如样例中,hehe可以是“呵呵”, 也可以是“o( ̄︶ ̄)o”,emmmm)。
问str1这句话可能有几种含义?

思路:

  • dp[i]表示以第i位结尾的字符串有几种意思
  • dp[0] = 1
  • 末尾的单词不能被匹配:dp[i] = dp[i - 1] //只能跟着前面的来解释,不可以被替换,所以dp不改变
  • 末尾后缀可以被str2(长度为m)替换:dp[i] = dp[i - m] + dp[i-1]//种类为被替换和不被替换两种加在一起
  • 判断末尾m位能否和str2匹配,可以用hash或者KMP解决

AC代码:

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <set>
#include <map>

using namespace std;

typedef long long LL;
typedef unsigned long long ULL;

const int maxn = 100005;
const int MOD = 1000000007;
ULL H[maxn], P[maxn], base = 27;
int dp[maxn];
char s1[maxn], s2[maxn];

void Hash(char s[])
{
    int len = strlen(s + 1);
    H[0] = 0;
    P[0] = 1;
    for(int i = 1; i <= len; i++)
    {
        H[i] = H[i - 1] * base + s[i] - 'a' + 1;
        P[i] = P[i - 1] * base;
    }
}

ULL GetHash(int l, int r)
{
    return H[r] - H[l - 1] * P[r - l + 1];
}



int main()
{
    int t;
    scanf("%d", &t);
    for(int ks = 1; ks <= t; ks++)
    {
        scanf("%s%s", s1 + 1, s2 + 1);
        int l1 = strlen(s1 + 1), l2 = strlen(s2 + 1);
        Hash(s2);
        ULL a2 = GetHash(1, l2);
        Hash(s1);
        dp[0] = 1;
        for(int i = 1; i <= l1; i++)
        {
            if(i < l2)
            {
                dp[i] = dp[i - 1];
                continue ;
            }
            ULL a1 = GetHash(i - l2 + 1, i);
            if(a1 == a2)
                dp[i] = (dp[i - l2] + dp[i - 1]) % MOD;
            else
                dp[i] = dp[i - 1];
        }
        printf("Case #%d: %d\n", ks, dp[l1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值