Robberies(01背包)

Robberies

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 18 Accepted Submission(s) : 8
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

Sample Output
  
  
2 4 6

题目大意:给定测试组数T

                   输入Roy所能承受的最高被捕率,打算偷窃的银行个数n

                  n组银行所拥有的价值,偷窃该银行的被捕率

                  输出所能获得的最大期望

                 (别人的分析)这里涉及一个概率论的问题,如果用被抓率来算是加法,用逃脱率来说是乘法,因为总的被抓率等于每一次被抓率的总和(或的关系|只要有一次被抓就失败了)。逃脱率的话等于每一次逃脱率的乘积(且的关系|保证每次逃脱才算成功)。

#include<cstdio>
#include<cstring>
#define max(a,b) (a>b?a:b)
using namespace std;
int main()
{
    int cases,n,i,j,sum,M[110];
    double MaxP,tmp,P[110],dp[10010];
    scanf("%d",&cases);
    while(cases--)
    {
        
        scanf("%lf%d",&MaxP,&n);
        MaxP=1-MaxP;//最低逃跑率 
        sum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d%lf",&M[i],&tmp);
            sum+=M[i];
            P[i]=1-tmp;
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;//没偷的时候逃脱率为1;
        for(i=1;i<=n;i++)
         for(j=sum;j>=M[i];j--)
          dp[j]=max(dp[j],dp[j-M[i]]*P[i]);
        for(i=sum;i>=0;i--)
         if(dp[i]>=MaxP){
           printf("%d\n",i);//大于给定逃脱率的最大收益 
           break;
         }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值