Ignatius and the Princess III(拆分数)

Ignatius and the Princess III

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4 Accepted Submission(s) : 4
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
  
  
4 10 20

Sample Output
  
  
5 42 627

Author
Ignatius.L

http://fudq.blog.163.com/blog/static/191350238201162535640887/

经典题,递推递归。

首先,我们引进一个小小概念来方便描述吧,record[n][m]是把自然数划分成所有元素不大于m的分法,例如:

当n=4,m=1时,要求所有的元素都比m小,所以划分法只有1种:{1,1,1,1};

当n=4,m=2时,。。。。。。。。。。。。。。。。只有3种{1,1,1,1},{2,1,1},{2,2};

当n=4,m=3时,。。。。。。。。。。。。。。。。只有4种{1,1,1,1},{2,1,1},{2,2},{3,1};

当n=4,m=5时,。。。。。。。。。。。。。。。。只有5种{1,1,1,1},{2,1,1},{2,2},{3,1},{4};

从上面我们可以发现:当n==1||m==1时,只有一种分法;

当n<m时,由于分法不可能出现负数,所以record[n][m]=record[n][n];

当n==m时,那么就得分析是否要分出m这一个数,如果要分那就只有一种{m},要是不分,那就是把n分成不大于m-1的若干份;即record[n][n]=1+record[n][n-1];

当n>m时,那么就得分析是否要分出m这一个数,如果要分那就{{m},{x1,x2,x3..}}时n-m的分法record[n-m][m],要是不分,那就是把n分成不大于m-1的若干份;即record[n][m]=record[n-m][m]+record[n][m-1];

那么其递归式:

record[n][m]= 1 (n==1||m==1)

record[n][n] (n<m)

1+record[n][m-1] (n==m)

record[n-m][m]+record[n][m-1] (N>m)

#include<cstdio>
using namespace std;
const int M=125;
int main()
{
    int i,j,n,a[M][M];
    for(i=1;i<M;i++)
     a[i][1]=a[1][i]=1;
    for(i=2;i<M;i++)
     for(j=2;j<M;j++)
     {
         if(i<j)
          a[i][j]=a[i][i];
         if(i==j)
          a[i][j]=a[i][j-1]+1;
         if(i>j)
          a[i][j]=a[i-j][j]+a[i][j-1];
     }
    while(~scanf("%d",&n))
     printf("%d\n",a[n][n]);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值