Ignatius and the Princess III(母函数版整数拆分)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14015    Accepted Submission(s): 9875


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

Author
#include <stdio.h>
int main()
{
	int n,i,j,k,a[125],b[125];
	while (scanf("%d",&n)!=EOF)
	{
		for (i=0;i<=n;i++)
		{
			a[i]=1;
			b[i]=0;
		}
		for (i=2;i<=n;i++)
		{
			for (j=0;j<=n;j++)
			{
				for (k=0;k+j<=n;k+=i)
				{
					b[j+k]+=a[j];
				}
			}
			for (j=0;j<=n;j++)
			{
				a[j]=b[j];
				b[j]=0;
			}
		}
		printf("%d\n",a[n]);
	}
}

我相信有很多人看母函数时一头雾水,其实仔细想想还是可以接受的!
母函数的详解请看母函数详解
我们真正要做的就是怎么把这个公式与整数拆分相结合,看看那个博文知道这个公式是怎么来的!
我想做的就是推倒!
从那篇文章可以看到,我们求N(假如为4)的拆分方式,即为求X的指数为4的数的系数,因为系数即为拆分的方法数!
下面我们一步一步的看实现代码:
#include <stdio.h>
int main()
{
	int n,i,j,k,a[125],b[125];//a[]数组为记录每一数的系数,b[]数组为中介数组
	while (scanf("%d",&n)!=EOF)
	{
		for (i=0;i<=n;i++)
		{
			a[i]=1;
			b[i]=0;
		}//这个意思是把第一个乘式(a[])的每一个系数设为1
		for (i=2;i<=n;i++)//i代表每一个乘式
		{
			for (j=0;j<=n;j++)//j是一个普通的数
			{
				for (k=0;k+j<=n;k+=i)//k是指数,这一点代码,简直就是模拟数学多项式乘法的过程,用纸操作一下你就会了!
				{
					b[j+k]+=a[j];//这个就是+=,因为指数相同的时候就认为他就成功拆分了一次
				}
			}//这个地方我感觉很难理解,但是我们要知道他要干什么?对,这个代码要做的就是怎么把那个公式的乘法求各个指数的系数用代码实现!
			for (j=0;j<=n;j++)
			{
				a[j]=b[j];
				b[j]=0;
			}
		}
		printf("%d\n",a[n]);
	}
}


  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值