PAT(A) - 1099. Build A Binary Search Tree (30)

22 篇文章 0 订阅


1099. Build A Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:
    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    
    Sample Output:
    58 25 82 11 38 67 45 73 42


思路分析:根据输入先建立一棵各节点值为空的二叉树,然后再填入相应的值。因为二叉搜索树的中序遍历就是一序列数的升序排列。所有先将输入的数组升序排列,再中序DFS遍历已建好的二叉树,填入当前结点的相应值。最后用队列层序遍历一遍就OK了。


#include <cstdio>
#include <queue>
#include <algorithm>

#define MAX 101

using namespace std;

typedef struct {
    int index;
    int lchild;
    int rchild;
    int data;
} Node;

Node node[MAX];
int a[MAX];
int index = 0;
void dfs( int curRoot ) {
    if( node[curRoot].lchild != -1 ) {
        dfs( node[curRoot].lchild );
    }

    node[curRoot].data = a[index++];
    //printf( " %d\n", node[curRoot].data );

    if( node[curRoot].rchild != -1 ) {
        dfs( node[curRoot].rchild );
    }
}

int main() {
    //freopen( "123.txt", "r", stdin );
    int n;
    scanf( "%d", &n );

    int isRoot[MAX] = { 0 };

    for( int i = 0; i < n; i++ ) {
        int left, right;
        scanf( "%d%d", &left, &right );
        node[i].lchild = left;
        node[i].rchild = right;
        node[i].data = -1;
        node[i].index = i;
        if( left != -1 ) {
            isRoot[left] = 1;
        }
        if( right != -1 ) {
            isRoot[right] = 1;
        }
    }

    int root = 0;
    for( int i = 0; i < n; i++ ) {
        if( isRoot[i] == 0 ) {
            root = i;
            break;
        }
    }

    for( int i = 0; i < n; i++ ) {
        scanf( "%d", &a[i] );
    }

    sort( a, a + n );

    //for( int i = 0; i < n; i++ ) {
    //    printf( "%d %d %d\n", node[i].index, node[i].lchild, node[i].rchild );
    //}
    //for( int i = 0; i < n; i++ ) {
    //   printf( "%d ", a[i] );
    //}

    //printf( "\n" );

    dfs( root );

    queue<Node> q;
    q.push( node[root] );
    int count = 0;

    while( !q.empty() ) {
        Node n = q.front();
        q.pop();
        if( count == 0 ) {
            printf( "%d", n.data );
            count = 1;
        }
        else {
            printf( " %d", n.data );
        }
        if( n.lchild != -1 ) q.push( node[n.lchild] );
        if( n.rchild != -1 ) q.push( node[n.rchild] );
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值