PAT(A) - 1038. Recover the Smallest Number (30)


Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

思路分析:我参考的别人程序,思路很巧妙。贪心:直接比较相邻的两个数字(这里输入的数字用string类型),如果a + b < b + a,则说明a + b组合成的数字一定小。这样就相当于一个冒泡排序,依次比较两个相邻的数字,写一个sort函数就OK了。以后遇到这种题方法应该也是适用的。


# include <cstdio>
# include <iostream>
# include <string>
# include <algorithm>
using namespace std;

const int _size = 10000;
string num[_size];
bool cmp(const string& a,const string& b){return a + b< b + a;}

int main() {
    int n;
    scanf( "%d", &n );

    for( int i = 0; i < n; i++ ) {
        cin >> num[i];
    }
    sort( num, num + n, cmp );

    string ans;
    for( int i = 0; i < n; i++ ) {
        ans += num[i];
    }
    //printf( "size:%d", ans.size() );
    int i;
    for( i = 0; i < ans.size(); i++ ) {
        if( ans[i] == '0' ) continue;
        else break;
    }
    if( i == ans.size() ) printf( "0" );
    for( ; i < ans.size(); i++ ) {
        cout << ans[i];
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值