PAT(A) - 1132. Cut Integer (20)

1132. Cut Integer (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=231). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line "Yes" if it is such a number, or "No" if not.

Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No

题意很好理解,需要注意的坑是如果除数出现0,则要输出No。例如输入1000,应该输出No

#include <iostream>
#include <string>

using namespace std;

int main() {
    int n;
    string str;
    cin >> n;

    while( n-- ) {
        cin >> str;
        int len = str.size();
        int A = 0;
        int B = 0;
        int Z = 0;
        for( int i = 0; i < len; i++ ) {
            Z = Z * 10 + str[i] - '0';
            if( i < len / 2 ) A = A * 10 + str[i] - '0';
            else B = B * 10 + str[i] - '0';
        }

        if( A == 0 || B == 0 ) { printf( "No\n" ); continue; }
        int t = Z / ( A * B );

        printf( "%s\n", t * A * B == Z ? "Yes" : "No" );
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值