POJ-2559 Largest Rectangle in a Histogram

5 篇文章 0 订阅
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint
Huge input, scanf is recommended.

单调栈的经典问题,也是一道面试题。

// 题号:POJ 2559
// 单调栈 经典问题
// 有连续排列在一起的若干长方形,它们的宽相等,高不等
// 求它们能构成的最大的矩形面积

// 假设最大的矩形是X,可以肯定X的高一定是某个输入矩形的高
// 所以问题转换成求每个矩形,找左、右第一个比它低的矩形位置
// 然后计算面积求最大值
// 整个算法时间复杂度O(n)

// 注意单调栈里存的是数组下标,不是数组的值
// 也可以用数组模拟栈,效率更高

#include <cstdio>
#include <stack>
#include <cstring>

#define MAX 100010

using namespace std;

typedef long long LL;

LL h[MAX];
int left[MAX];
int right[MAX];

int main() {
    int n;
    while( scanf( "%d", &n ) != EOF && n ) {
        memset( h, 0, sizeof( h ) );
        memset( left, -1, sizeof( left ) );
        memset( right, -1, sizeof( right ) );
        for( int i = 0; i < n; i++ ) {
            scanf( "%lld", &h[i] );
        }

        // 找每个节点右边第一个小于它的位置
        stack<int> s;
        for( int i = 0; i < n; i++ ) {
            while( !s.empty() && h[s.top()] > h[i] ) {
                right[s.top()] = i;
                s.pop();
            }
            s.push( i );
        }

        // 把栈清空
        while( !s.empty() ) s.pop();

        // 找每个节点左边第一个小于它的位置
        for( int i = n - 1; i >= 0; i-- ) {
            while( !s.empty() && h[s.top()] > h[i] ) {
                left[s.top()] = i;
                s.pop();
            }
            s.push( i );
        }

        LL ans = 0;
        for( int i = 0; i < n; i++ ) {
            int l = left[i] == -1 ? -1 : left[i];   // int l = left[i];
            int r = right[i] == -1 ? n : right[i];
            LL cur = ( r - l - 1 ) * h[i];
            //printf( "%d %d %lld\n", l, r, cur );
            if( cur > ans ) ans = cur;
        }

        printf( "%lld\n", ans );
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值