HDU 5441(并查集)

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2937    Accepted Submission(s): 1006


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are  n  cities and  m  bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is  x  minutes, how many pairs of city  (a,b)  are there that Jack can travel from city  a  to  b  without going berserk?
 

Input
The first line contains one integer  T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers  n,m  and  q  where  n20000,m100000,q5000 . The Undirected Kingdom has  n  cities and  m bidirectional roads, and there are  q  queries.

Each of the following  m  lines consists of three integers  a,b  and  d  where  a,b{1,...,n}  and  d100000 . It takes Jack  d  minutes to travel from city  a  to city  b and vice versa.

Then  q  lines follow. Each of them is a query consisting of an integer  x  where  x  is the time limit before Jack goes berserk.

 

Output
You should print  q  lines for each test case. Each of them contains one integer as the number of pair of cities  (a,b)  which Jack may travel from  a  to  b  within the time limit  x .

Note that  (a,b)  and  (b,a)  are counted as different pairs and  a  and  b  must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
 

Source
 

Recommend

hujie   |   We have carefully selected several similar problems for you:  5803 5802 5801 5800 5799 

将边和询问存下来,将边按照权值从小到大排序, 将询问从小到大排序。从小到大添边,用并查集将边连起来。

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010 + 100;
struct tt{
    int from;
    int to;
    int x;
    friend bool operator <(tt p1, tt p2){
        return p1.x < p2.x;
    }
}a[maxn];
struct query{
    int id;
    int x;
    friend bool operator <(query p1, query p2){
        return p1.x < p2.x;
    }
}b[maxn];
int p[maxn];
int find(int x){
    return x == p[x] ? x : p[x] = find(p[x]);
}
int qq[maxn];
int num[maxn];
int main(){
    int T;
    scanf("%d", &T);
    while(T--){
       int n, m, q;
       scanf("%d%d%d", &n, &m, &q);
       for(int i = 0; i < m; i++){
           int x, y, t;
           scanf("%d%d%d", &a[i].from, &a[i].to, &a[i].x);
       }
       for(int i = 1; i <= n; i++) p[i] = i, num[i] = 1;
       for(int i = 0; i < q; i++){
        scanf("%d", &b[i].x);
        b[i].id = i;
       }
       sort(a, a + m);
       sort(b, b + q);
       int j = 0, ans = 0;
       for(int i = 0; i < q; i++){
           while(j < m && a[j].x <= b[i].x){
                int t1 = find(a[j].from);
                int t2 = find(a[j].to);
                if(t1 != t2){
                    ans += num[t1] * num[t2];
                    p[t1] = t2;
                    num[t2] += num[t1];
                }
                j++;
           }
           qq[b[i].id] = 2 * ans;
       }
       for(int i = 0; i < q; i++)
           printf("%d\n", qq[i]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值