【链表】链表的逆置,有序链表的归并

1.链表的逆置

/*
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。 
Sample Input:12 56 4 6 55 15 33 62 -1
Sample Output:62 33 15 55 6 4 56 12 
*/
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat()
{
    struct node *p,*head,*tail;
    int x;
    head=(struct node*)malloc(sizeof(struct node));
    tail=head;
    while(scanf("%d",&x)!=EOF&&x!=-1)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->data=x;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
}
struct node *re(struct node *head)
{
    struct node *p,*q;//q为将要转置链的后指针(紧跟p)
    p=head->next;
    q=p->next;
    head->next=NULL;
    while(p)
    {
        p->next=head->next;
        head->next=p;
        p=q;
        if(q)
            q=q->next;
    }
return head;
}
int main()
{
    struct node *head,*p;
    head=creat();
    head=re(head);
    p=head->next;
    while(p)
    {
        printf("%d",p->data);
        if(p->next)printf(" ");
        else printf("\n");
        p=p->next;
    }
    return 0;
}

2.有序链表的归并 

/*
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;第二行依次输入M个有序的整数;第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
*/
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int x)
{
    struct node *head,*tail,*p;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    while(x--)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};
struct node *gb(struct node *head1,struct node *head2)
{
    struct node *p1,*p2,*q1,*q2,*tail;
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data<=p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
            //tail->next=NULL;//aaaaaaaaaaaaaaaaaaaaaaa
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
            //tail->next=NULL;
        }
    }
    if(p1)
        tail->next=p1;
    else if(p2)
        tail->next=p2;
    return head1;
};
int main()
{
    int n,m;
    struct node *head,*head1,*head2,*p;
    scanf("%d%d",&m,&n);
    head1=creat(m);
    head2=creat(n);
    head=gb(head1,head2);
    p=head->next;
    while(p)
    {
        printf("%d",p->data);
        if(p->next)
            printf(" ");
        else printf("\n");
        p=p->next;//bbbbbb
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值