hdoj 1056 HangOver

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1056


How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.


For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.


Sample Input
1.00
3.71
0.04
5.19
0.00
 
Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)

----------------------------------

题目倒是挺长的,题意倒是比较清楚。要注意判断浮点数相等的方式。

判断浮点数相等的情况,在这一题中,第一个出现在判断输入是否为0.00的时候,OJ对这点倒不用意。第二个判断累加之和len与给定值C的大小时才在意,这是在题目的Discuss中很多人讨论用float会WA,而用double类型才AC。用double类型的代码如下:

#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
    int cnt;
    double C, len;
    while(scanf("%lf", &C)!=EOF && fabs(C-0.0)>0.000001)
    {
        if(C<=0.5)
        {
            printf("1 card(s)\n");
            continue;
        }
        else
        {
            cnt = 1;
            len = 0.5;
            while(len<C)
            {
                ++cnt;
                len += 1.0/(1+cnt);
            }
            printf("%d card(s)\n", cnt);
        }
    }
    return 0;
}

用float类型的话在while(len<C)这句改成while(C-len>0.000001)就OK了,笔者用两种方法亲测AC。但为什么只有在double类型才会较好的判断len<C的问题,这应该和精度有关(这不白说嘛,double精度比float高多了),反正以后对浮点数的比较还是用差值小于一个比较小的值(比如0.000001)来比较好。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值