hdoj 1163 Eddy's digital Roots

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1163

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.


For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 
Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output
Output n^n's digital root on a separate line of the output.

Sample Input
2
4
0

Sample Output
4

4


AC完了之后看了一下Discuss,这题是考九余数定理的。

如果google一下九余数定理,这题就比较简单了,比如这位博主的解法http://blog.csdn.net/niushuai666/article/details/6856109

笔者用的是一次一次累乘,每一次的中间结果取digital roots。比如求4的4次方的digital roots,先4乘以4得16,16的digital roots是7,下次就用7乘以4,得到的digital是1,再乘以4得到的digital roots是4. 当然仔细考虑的话可以直接用4的平方的digtial roots7乘以7得到49,其digital roots是4.即用二分治法来解决,所以说笔者下面AC的代码从哪里来说都不是最简洁的。至少在循环乘的时候可以从O(N)改善到O(logN).

代码有点冗余,另外要注意stl里的累加accumulate函数的应用,免得自己去写。

#include<cstdio>
#include<vector>
#include<numeric>
using namespace std;

int main()
{
    int N, num;
    vector<int>vec;
    while(scanf("%d", &N) && N)
    {
        num = N;
        vec.clear();
        while(num >= 10)
        {
            vec.push_back(num%10);
            num /= 10;
        }
        vec.push_back(num);
        num = accumulate(vec.begin(), vec.end(), 0);

        int sum = num;
        for(int i = 1; i < N; ++i)
        {
            sum *= num;
            vec.clear();
            while(sum >= 10)
            {
                vec.push_back(sum%10);
                sum /= 10;
            }
            vec.push_back(sum);
            sum = accumulate(vec.begin(), vec.end(), 0);
        }

        vec.clear();
        while(sum >= 10)
        {
            vec.push_back(sum%10);
            sum /= 10;
        }
        vec.push_back(sum);
        sum = accumulate(vec.begin(), vec.end(), 0);
        printf("%d\n", sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值