题目:http://acm.hdu.edu.cn/showproblem.php?pid=1164
Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
11
9412
Sample Output
11
2*2*13*181
很不可思议的水过,在写的同时在想这博客是不是也是很水,好吧,水就水点吧,我之前还以为暴力解会LTE呢,想着会有奇妙的解法,然而就这样水过。
15MS,208K
#include<cstdio>
using namespace std;
int main()
{
int num, cnt;
while(scanf("%d", &num)==1)
{
cnt = 0;
for(int i = 2; i<=65535 && num!=1; ++i)
{
while(num%i==0)
{
cnt>0 ? printf("*%d", i) : printf("%d", i);
++cnt;
num /= i;
}
}
printf("\n");
}
return 0;
}