LightOJ - 1027 A Dangerous Maze

                                        A Dangerous Maze

 

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the i th door, it can either take you back to the same position where you begun in x i minutes, or can take you out of the maze after x i minutes. If you come back to the same position, you can 't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

 

Input

Input starts with an integer T ( ≤ 100) , denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the i th integer (x i ) is positive, you can assume that the i th door will take you out of maze after x i minutes. If it's negative, then the i th door will take you back to the beginning position after abs(x i ) minutes. You can safely assume that 1 ≤ abs(x i ) ≤ 10000 .


Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf' . Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

本题的题意:在一个迷宫里,有n个门,如果ai是正数,那么在ai时间后,将要走出迷宫,如果是负数的话,他将要在ai时间后,重新开始选择,并且忘记以前的记忆。求走出迷宫的时间期望。

设门的总数是N, 有N1 个门可以走出迷宫, N2 个门会返回原来的位置. T1为总的总出迷宫的时间, T2为总的返回原位的时间

          则 P(走出迷宫)= N1 / N ,  P(返回)= N2 / N,

          题目转化为需要多少实验才能取得成功.

          随机变量X符合几何分布...

 此题目中

p= N1 / N 

期望实验次数: E(X)= N / N1    //本题关键...若打开姿势不对..必挂T^T

每次实验消耗的时间: T= (T1 + T2) /  N

所需时间的数学期望: E(T)=(N / N1) * ( ( T1 + T2) / N) =( T1 + T2) / N1;

 

#include<bits/stdc++.h>
using namespace std;
int a[105];
int T , n;
int gcd(int x ,int y){
    while(y){
        int t = x % y;
        x = y;
        y = t;
    }
    return x;
}
int main(){
    cin >> T;
    int t = 1;
    while(T--){
        int num = 0 , sum  = 0;
        cin >> n;
        for(int i = 1;i <= n;i++){
            cin >> a[i];
            if(a[i] > 0) num++;
            sum += abs(a[i]);
        }
        printf("Case %d: ",t++);
        if(!num)printf("inf\n");
        else{
            //cout << sum <<endl <<num;
            int flag = gcd(sum , num);
           // cout << sum / flag <<"/"<<num/flag;
            printf("%d/%d\n",sum/flag , num/flag);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值