某月某日是某年的第几天

题目描述

定义一个结构体变量(包括年、月、日)。计算该日在本年中是第几天,注意闰年问题。

输入

年月日

输出

当年第几天

样例输入

2000 12 31

样例输出

366


#include <stdio.h>




int dayOfMonth[13] = {0,31,60,91,121,152,182,213,244,274,305,335,366};




int main() {
int m,year,month,date;

while (scanf("%d %d %d\n",&year,&month,&date)!=EOF) {

if(year%4 == 0 && year%100 !=0 || year%400 == 0) {               
if(month<=2)  printf("%d\n",(month-1)*31+date);
if (month>2) {
           int total= dayOfMonth[month-1]+date;
printf("%d\n",total );
}


} else {
if(month<=2)  printf("%d\n",(month-1)*31+date);
if (month>2) {
       int total= dayOfMonth[month-1]+date-1;
printf("%d\n",total );


}
}



}


return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

foreverlove111

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值