poj 2406

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 48557 Accepted: 20207
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.
Sample Output

1
4
3
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:给你一个字符串a,问a最多由几个完全相同的子串连接而成
做法:若存在这样的连接则连接数为n/(n-next[n-1])
若不存在则这个式子不会是一个整数,那么输出1就好了。
代码如下:

#include <cstdio>
#include <iostream>
#include <string>
using namespace std;
char a[2000000];
int p[2000000];
int main()
{
    while (scanf("%s",&a)>0)
    {
        if (a[0]=='.')  return 0;
        p[0]=-1;
        int j=-1;
        int m=strlen(a);
        for (int i=1;i<=m-1;i++)
        {
            while (j>-1&&a[j+1]!=a[i])  j=p[j];
            if (a[j+1]==a[i])   j++;
            p[i]=j;
        }
        if (m%(m-p[m-1]-1)!=0)  cout<<1<<endl;
        else if (m%(m-p[m-1]-1)==0) cout<<m/(m-p[m-1]-1)<<endl;
    }   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值