UVA 11549(计算器谜题)

题目描述:
Alice got a hold of an old calculator that can display n digits. She was bored enough to come up with
the following time waster.
She enters a number k then repeatedly squares it until the result overflows. When the result
overflows, only the n most significant digits are displayed on the screen and an error flag appears. Alice
can clear the error and continue squaring the displayed number. She got bored by this soon enough,
but wondered:
“Given n and k, what is the largest number I can get by wasting time in this manner?”
Input
The first line of the input contains an integer t (1 ≤ t ≤ 200), the number of test cases. Each test case
contains two integers n (1 ≤ n ≤ 9) and k (0 ≤ k < 10n) where n is the number of digits this calculator
can display k is the starting number.
Output
For each test case, print the maximum number that Alice can get by repeatedly squaring the starting
number as described.
Sample Input
2
1 6
2 99
Sample Output
9
99

题意:
有个老式计算器,只能显示n位数字。现在输入一个整数k,然后反复平方,一直做下去,能得到的最大数是多少。例如,n=1,k=6,那么一次显示:6,3,9,1…
算法:Floyd判圈算法;
ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int fun(int n,int k);
int a[22];
int main()
{
    int cas;
    cin >> cas;
    while(cas--)
    {
        int n,k;
        cin >> n >> k;
        int ans=k;
        int k1=k,k2=k;
        do
        {
            k1=fun(n,k1);
            k2=fun(n,k2);
            ans=max(ans,k2);
            k2=fun(n,k2);
            ans=max(ans,k2);
        }while(k1!=k2);
        cout << ans <<endl;
    }
    return 0;
}
int fun(int n,int k)
{
    long long num=(long long)k*k;
    int i=0;
    while(num)
    {
        a[i++]=num%10;
        num/=10;
    }
    int ans=0;
    n=min(n,i);
    for(int j=i-1;j>=i-n;j--)
    ans=ans*10+a[j];
    return ans;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值